情報工学実験1「情報ネットワーク演習1」(2コマ)

【目次】


【注意事項】

  1. 実習は4名のグループ単位で行う。(最大9グループまで)
  2. 実習テーマであるため「欠席=不可(F)」(=実験1が不可(F))となるので注意すること。

到達目標

本実験テーマでは、以下の項目に関するスキルを習得することを目標とする。

  1. PCのネットワーク設定の理解
  2. ルーターの基本設定の理解
    1. コンソールを使った設定
    2. ログインパスワード、特権パスワードの設定
    3. ネットワークインターフェースの設定
  3. Peer-to-Peerネットワークの構築
  4. スタティックルーティングによる経路制御
  5. ダイナミックルーティング(OSPF)による経路制御
  6. ネットワーク構築のトラブルシューティング

事前準備

使用機材

情報ネットワーク演習1,2では、以下のネットワーク機材を使用する。

  • ルーター
  • YAMAHA RTX1200 一式
  • Cisco Cisco1841 一式
    *機種ごとに設定方法が異なるため、2週ともグループメンバーは同一とし、同一機種を使用すること。
  • スイッチングハブ
  • Fujitsu SR-S308TL1 一式 (実験2:情報ネットワーク演習2で使用)
  • その他
  • USBシリアル変換ケーブル
  • ロールオーバーケーブル
  • LANケーブル(UTPケーブル) *自己所有のLANケーブルを持参すること。
  • LANケーブル作成工具キット (実験2:情報ネットワーク演習2で使用)
  • LANケーブル・テスター (実験2:情報ネットワーク演習2で使用)
  • USB-LANアダプター (2014年度以降の入学生のMac Bookで使用)

なお、以下のすべの演習は、Mac Bookは有線LAN接続(無線LANは切ること)及びファイアウォールは無効の状態で行うこと。

USBシリアル変換ケーブルのデバイスドライバーのインストール

USBシリアル変換ケーブルは以下の2種類がある。使用するケーブルのドライバーをインストールする。


1 Peer-to-Peerネットワークの構築

LANケーブル(UTPケーブル)接続によるルーターとPC間のPeer-to-Peerネットワークを構築する。

img1-1.png
【図1.1: 想定ネットワーク(Peer-to-Peerネットワーク)】

1.1 PCのネットワーク設定(手入力設定)

  • [アップルメニュー]->[システム環境設定]->[ネットワーク]を開く。
  • 左下の[+]をクリックし、実験用に「新しいサービス」を作成する。
    ここで、インターフェースは「Ethernet(or USB Ethernet)」、サービス名は「slab1-infonet1」とする。
  • 新しいサービスを作成したら、以下の内容を設定する。
    ここで、[IPv4の構成]は「手入力」とする。
    IPアドレス: 192.168.0.1
    サブネットマスク: 255.255.255.0
    ルーター,DNSサーバー: (設定不要)
    802.1X: (初期値のままでok)
    *192.168.0.1はどのようなアドレスか?(ヒント:グローバルアドレスとプライベートアドレス*末尾のメモ参照)
  • 上記の設定をしたら、右下の[適用]をクリックする。

1.2 ルーターのネットワーク設定

以下のものを箱から取り出して下さい。

  1. ルーター本体
  2. シリアルケーブル(YAMAHAの場合)
  3. ロールオーバーケーブル(Ciscoの場合)
  4. 電源ケーブル(Ciscoの場合)

USBシリアル変換ケーブルは別途配布します。

1.2.1 コンソールを使ってルーターを設定する方法

  • PCのUSBポートにUSBシリアル変換ケーブルを接続し、ルーターのCONSOLEポートに接続する。
    ここで、ロールオーバーケーブルをジョイントケーブルとして使用する。
  • ルーターのコンソールを表示するには、PCのターミナルを起動して以下のコマンドを実行する。
[書式]
screen {デバイスファイル名}
[実行例]
screen /dev/cu.usbserial-(英数字文字列) (REX-USB60Fの場合)
screen /dev/cu.usbserial (BHC-US01/GPの場合)

上記の通りscreenコマンドを実行すると、ルーターのコンソールに初期アクセスすることができる。

(注意)
screenコマンド実行中は、USBシリアル変換ケーブルはPCから絶対に抜かないこと(PCがハングアップします)。
もし、どうしてもUSBシリアル変換ケーブルを抜きたい場合は、screenコマンドのプロセルIDを調べてscreenコマンドプロセスを強制停止した後にケーブルを抜けばよい。(下記参照)

(screenコマンドを実行しているものとは別のコマンドプロンプトを開く)
# ps x | grep screen (screenコマンドのプロセスIDを確認する)
# kill -9 (screenコマンドのプロセスID)

1.2.2 ルーターの基本操作

ルーターのコンソールに初期アクセスした状態を「ログインモード」、管理者権限で操作できる状態を「特権モード」と呼ぶ。

ルーターを設定するには、ログインモードから特権モードに切り替える必要がある。

以下では、異なる2機種のルーター(YAMAHA RTX1200, Csico Cisco1841)について別々に設定方法・設定例を示すので、注意すること。

  • ルーターでログインモードから特権モードに切り替えるには、以下のコマンドを実行する。
(YAMAHA RTX1200の場合)
> administrator
#
*ログインモードから特権モードに切り替わるとプロンプトが">"から"#"に変わる。
(Cisco Cisco1841の場合)
Router>enable (ena)
Router#
*ログインモードから特権モードに切り替わるとプロンプトが"Router>"から"Router#"に変わる。
*()は省略形
  • YAMAHAの場合は、以下の設定コマンドをあらかじめ設定しておくとよい。
(YAMAHA RTX1200の場合)
# console character ascii *コンソール表示をASCII文字に設定
# login timer 1200 *自動ログアウト時間を20分(1200秒)に設定

ルーターには、「ログインパスワード」及び「特権パスワード」を設定することができる。

パスワードを設定することによって、初期アクセス及び特権モードに切り替える際にパスワード入力が必要になる。

  • ログインパスワード及び特権パスワードを設定するには、以下の設定コマンドを実行する。
    なお、以下の操作は特権モードで行う必要がある。
(YAMAHA RTX1200の場合)
# login password
Old_Password: (古いパスワードを入力)
New_Password: (新しいパスワードを入力)
New_Password: (新しいパスワードを入力(確認))
*古いパスワードと新しいパスワード(2回)の入力を求められる。
# administrator password
Old_Password: (古いパスワードを入力)
New_Password: (新しいパスワードを入力)
New_Password: (新しいパスワードを入力(確認))
*古いパスワードと新しいパスワード(2回)の入力を求められる。
  • ログインパスワード及び特権パスワードが正しく設定されたかを確認するため、"exit"コマンドでログアウトしてから再度ログインしてみるとよい。
    (YAMAHAの場合は、"exit"コマンドでログアウトすると、設定を保存するか聞かれるので、"N"(保存しない)を選択すること)
  • Ciscoの場合は、特権モードから、さらに「設定モード」に入って設定を行う必要がある。(YAMAHAの場合は、設定モードはない)
(Cisco Cisco1841の場合)
Router#configure terminal (conf term)
Router(config)#
*設定モードに入るとプロンプトが"Router#"から"Router(config)#"に変わる。
*設定モードに入った直後の状態を「グローバル設定モード」と呼ぶ。
*()は省略形
  • 特権パスワードを設定するには、以下の設定コマンドを入力する。
(Cisco Cisco1841の場合)
Router(config)#enable password class (ena pass class)
*"class"はパスワードに使用する文字列(任意の文字列でok)
*()は省略形

Ciscoの場合は、初期アクセスするインターフェースごとにログインパスワードを設定する必要がある。

  • ログインパスワードを設定するには、以下の設定コマンドを入力する。
(Cisco Cisco1841の場合)
Router(config)#line console 0 (line con 0)
Router(config-line)#password cisco (pass cisco)
Router(config-line)#login
*グローバル設定モードからライン設定モードに入るとプロンプトが"Router(config)#"から"Router(config-line)#"に変わる。
*"cisco"はパスワードに使用する文字列(任意の文字列でok)
*()は省略形
  • 設定が終わったら設定モードから抜ける。
(Cisco Cisco1841の場合)
Router(config)#exit (ex)
または
Router(config)#end
*設定モードの時は"exit"はその時点の設定モードを1段階戻る場合に使用する。
*特権モードの時は"exit"はログアウトするために使用する。
*その時点の設定モードに関わらず"end"は設定モードを終了する場合に使用する。
*()は省略形
  • ログインパスワード及び特権パスワードが正しく設定されたかを確認するため、"exit"コマンドでログアウトしてから再度ログインしてみるとよい。
  • 現在の設定内容を確認するには、以下のコマンドを実行する。
(YAMAHA RTX1200の場合)
# show config
*"show"コマンドの後ろに様々な引数をつけることでルーターの状態を調べることができる。
(Cisco Cisco1841の場合)
Router#show running-config (sh run)
*"show"コマンドの後ろに様々な引数をつけることでルーターの状態を調べることができる。
*()は省略形
  • その時点で実行可能なコマンドや引数の候補リストを表示するには、以下のコマンドを実行する。
(YAMAHA RTX1200の場合)
?キーを押す
(Cisco Cisco1841の場合)
?キーを押す
  • また、YAMAHA及びCiscoとも、コマンド入力途中でタブキーを押すことによって、コマンドを補間してくれる。

ここまでで、以下の設定になっていればok。

1.2.3 ルーターのネットワークインターフェースの設定

  • ルーターのネットワークインターフェース(以下、ネットワークI/F)にIPアドレス、ネットマスクを設定するには、以下の設定コマンドを実行する。
(YAMAHA RTX1200の場合)
# ip lan1 address 192.168.0.2/24 *prefix表記
*lan1インターフェースに設定する場合
(Cisco Cisco1841の場合)
Router(config)#interface FastEthernet0/0 (int fa0/0)
Router(config-if)#ip address 192.168.0.2 255.255.255.0 (ip addr 192.168.0.2 255.255.255.0) *ドット区切りの10進表記
Router(config-if)#no shutdown (no shut)
*FaseEthernet0/0インターフェースに設定する場合
*グローバル設定モードからインターフェース設定モードに入るとプロンプトが"Router(config)#"から"Router(config-if)#"に変わる。
*()は省略形

ここまでで、以下の設定になっていればok。

1.3 疎通確認

  • pingコマンドを使って疎通確認する。(実験1:ネットワーク管理コマンド活用で演習済み)
[書式]
ping {確認相手のIPアドレスorドメインネーム}
[実行例]
ping 192.168.0.1 (ルーターからPC向け)
ping 192.168.0.2 (PCからルーター向け)
*PCは無線LANを「切」にしてから疎通確認すること。

pingのエコー応答が返ってきたら疎通ok。

2 スタティックルーティング・ネットワークの構築

ルーターを2台使って、シンプルなスタティック・ルーティングネットワークを構築する。

2グループで1組となって作業するので、組み分けを行う。

img2-1.png
【図2.1: 想定ネットワーク(スタティックルーティング・ネットワーク)】

2.1 ルーターのリセット

  • ルーターの設定を初期化する。
    これまでの操作で設定を保存していないので、ルーターを再起動すればよい。
    (設定は保存しないこと。また、電源を切ると設定が消えるので注意すること)
(YAMAHA RTX1200の場合)
# cold start
*特権パスワードを設定している場合はパスワードの入力を求められる。
(Cisco Cisco1841の場合)
Router#erase startup-config (erase start)
Router#reload
*設定を保存するか聞かれるが「no」を選択する。
*再起動の確認を求められるがそのままEnterキーを押す。
*再起動後に対話形式で初期設定するか聞かれるが「no」を選択する。
 (初期インストールを終了するか聞かれた場合はそのままEnterキーを押す)
  • YAMAHAの場合は、以下の設定コマンドをあらかじめ設定しておくとよい。
(YAMAHA RTX1200の場合)
# console character ascii *コンソール表示をASCII文字に設定
# login timer 1200 *自動ログアウト時間を20分(1200秒)に設定

2.2 ルーター・PCのネットワーク設定

1節の説明を参考にして、図2.1の通りに各ルーター及びPCのネットワークI/Fにネットワーク設定をする。

また、1.1節でのPCのネットワーク設定で[ルーター]は設定不要だったが、ここでは設定が必要である。これは、そのPCが直接つながっていないネットワークと通信できるようにするためである。

2.3 ルーターのスタティックルーティングの設定

スタティックルーティングとは、そのルーターが直接通信できないネットワークへ到達するためのゲートウェイ(そのルーターが直接通信できる別のルーター)のIPアドレスを静的に設定することで、別のネットワークとの通信を可能にする経路制御のことである。

  • ルーターにスタティックルーティングの設定をするには、以下の設定コマンドを実行する。
(YAMAHA RTX1200の場合)
[書式]
ip route (対象ネットワークアドレス)/(ネットマスク*prefix表記) gateway (ルーターのIPアドレス)
[実行例]
# ip route 192.168.20.0/24 gateway 192.168.0.2 (ルーター1の場合)
# ip route 192.168.10.0/24 gateway 192.168.0.1 (ルーター2の場合)
(Cisco Cisco1841の場合)
[書式]
ip route (対象ネットワークアドレス) (ネットマスク*ドット区切りの10進表記) (ルーターのIPアドレス)
[実行例]
Router(config)#ip route 192.168.20.0 255.255.255.0 192.168.0.2 (ルーター1の場合)
Router(config)#ip route 192.168.10.0 255.255.255.0 192.168.0.1 (ルーター2の場合)

スタティックルーティングは、そのルーターが直接つながっていない対象ネットワークに到達するために経由するルーターのIPアドレスを指定することがポイントである。

  • スタティックルーティングが正しく設定されているかを確認するには、以下のコマンドを実行してルーティングテーブルを確認する。
(YAMAHA RTX1200の場合)
[書式]
# show ip route
[実行例] *ルーター1の場合
# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
192.168.0.0/24      192.168.0.1            LAN2  implicit
192.168.10.0/24     192.168.10.1           LAN1  implicit
192.168.20.0/24     192.168.0.2            LAN2    static  <-スタティックルーティング設定によって追加された経路
#
(Cisco Cisco1841の場合)
[書式]
Router#show ip route
[実行例] *ルーター2の場合
Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.10.0/24 [1/0] via 192.168.0.1  <-スタティックルーティング設定によって追加された経路
C    192.168.20.0/24 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
Router#

ここまでで、以下の設定になっていればok。

最後に、各PCにデフォルトゲートウェイ(ルーター)を設定する。

PC1の場合 -> 192.168.10.1
PC2の場合 -> 192.168.20.1

2.4 疎通確認

  • pingコマンドを使って疎通確認する。(実験1:ネットワーク管理コマンド活用で演習済み)
[書式]
ping {確認相手のIPアドレスorドメインネーム}
[実行例]
ping 192.168.0.2 (PC1からルーター2向け)
ping 192.168.0.1 (PC2からルーター1向け)
ping 192.168.20.2 (PC1からPC2向け)
ping 192.168.10.2 (PC2からPC1向け)
*PCは無線LANを「切」にしてから疎通確認すること。

pingのエコー応答が返ってきたら疎通ok。

2.5 片づけ

各機材は、同梱品を含めて紛失がないように取り扱うこと。
(片付ける際は、本体は箱に貼られた番号の通りに箱詰めすること)

USBシリアル変換ケーブル、貸出LANケーブルは別回収です。(ルーターの箱に入れないこと)


(1週目はここまで)


3 ダイナミックルーティング・ネットワークの構築

ルーターを2台使って、シンプルなダイナミック・ルーティングネットワークを構築する。

2グループで1組となって作業するので、組み分けを行う。

img3-1.png
【図3.1: 想定ネットワーク(ダイナミックルーティング・ネットワーク)】

3.1 ルーターのリセット

  • ルーターの設定を初期化する。
    これまでの操作で設定を保存していないので、ルーターを再起動すればよい。
    (設定は保存しないこと。また、電源を切ると設定が消えるので注意すること)
(YAMAHA RTX1200の場合)
# cold start
*特権パスワードを設定している場合はパスワードの入力を求められる。
(Cisco Cisco1841の場合)
Router#erase startup-config (erase start)
Router#reload
*設定を保存するか聞かれるが「no」を選択する。
*再起動の確認を求められるがそのままEnterキーを押す。
*再起動後に対話形式で初期設定するか聞かれるが「no」を選択する。
 (初期インストールを終了するか聞かれた場合はそのままEnterキーを押す)
  • YAMAHAの場合は、以下の設定コマンドをあらかじめ設定しておくとよい。
(YAMAHA RTX1200の場合)
# console character ascii *コンソール表示をASCII文字に設定
# login timer 1200 *自動ログアウト時間を20分(1200秒)に設定

3.2 ルーター・PCのネットワーク設定

1節の説明を参考にして、図3.1の通りに各ルーター及びPCのネットワークI/Fにネットワーク設定をする。

また、1.1節でのPCのネットワーク設定で[ルーター]は設定不要だったが、ここでは設定が必要である。これは、そのPCが直接つながっていないネットワークと通信できるようにするためである。

3.3 ルーターのダイナミックルーティングの設定

ダイナミックルーティングとは、そのルーターが直接通信できないネットワークへ到達するためのゲートウェイ(そのルーターが直接通信できる別のルーター)のIPアドレスをダイナミックルーティングプロトコルによってルーター同士が動的に学習することで、別のネットワークとの通信を可能にする経路制御のことである。

  • ルーターにダイナミックルーティングの設定をするには、以下の設定コマンドを実行する。
    なお、本実験では、ダイナミックルーティングプロトコルの1つである「OSPF」を使用する。
(YAMAHA RTX1200の場合)
[書式]
# ospf use on *OSPFを有効化
# ospf area backbone *ルーターが所属するエリアを設定
# ip (ネットワークI/F) ospf area backbone *ネットワークI/Fが所属するエリアを設定
# ospf configure refresh *OSPF設定を有効化
[実行例] *ルーター1の場合
# ospf use on
# ospf area backbone
# ip lan1 ospf area backbone
# ip lan2 ospf area backbone
# ospf configure refresh
*各ネットワークI/Fにエリアを設定することで経路広告対象ネットワークを指定する。
*YAMAHAにおけるエリア:backboneは、Ciscoにおけるエリア:0に相当する。
*OSPFによる経路情報交換は、同一エリアに所属するルーター間のみで行われる。
(Cisco Cisco1841の場合)
[書式]
Router(config)#router ospf (プロセスID)
Router(config-router)#network (対象ネットワーク) (ネットマスク*ドット区切りの10進表記&ワイルドカード表記) 
[実行例] *ルーター2の場合
Router(config))#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.3 area 0
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
*"network"で経路広告対象ネットワークを指定する。
*Ciscoにおけるエリア:0は、YAMAHAにおけるエリア:backboneに相当する。
*OSPFによる経路情報交換は、同一エリアに所属するルーター間のみで行われる。

ダイナミックルーティングは、相手ルーターに経路広告する対象ネットワークを正しく指定することがポイントである。

  • ダイナミックルーティングが正しく設定されているかを確認するには、以下のコマンドを実行してルーティングテーブルを確認する。
(YAMAHA RTX1200の場合)
[書式]
# show ip route
[実行例]
# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
192.168.0.0/30      192.168.0.1            LAN1  implicit
192.168.10.0/24     192.168.0.2            LAN1      OSPF     cost=2  <-ダイナミックルーティング(OSPF)設定によって追加された経路
200.20.20.0/30      200.20.20.2            LAN2  implicit
#
(Cisco Cisco1841の場合)
[書式]
Router#show ip route
[実行例]
Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.20.20.0/30 is subnetted, 1 subnets
O       200.20.20.0 [110/2] via 192.168.0.1, 00:09:04, FastEthernet0/0  <-ダイナミックルーティング(OSPF)設定によって追加された経路
C    192.168.10.0/24 is directly connected, FastEthernet0/1
     192.168.0.0/30 is subnetted, 1 subnets
C       192.168.0.0 is directly connected, FastEthernet0/0
Router#

ここまでで、以下の設定になっていればok。

3.4 疎通確認

  • pingコマンドを使って疎通確認する。(実験1:ネットワーク管理コマンド活用で演習済み)
[書式]
ping {確認相手のIPアドレスorドメインネーム}
[実行例]
ping 192.168.10.1 (PC1からルーター2向け)
ping 192.168.0.1 (PC1からルーター1向け)
ping 200.20.20.1 (PC1からPC2向け)
ping 192.168.10.2 (PC2からPC1向け)
*PCは無線LANを「切」にしてから疎通確認すること。

pingのエコー応答が返ってきたら疎通ok。

4 トラブルシューティング

  1. 正常動作しないときは下位層(OSI参照モデル)から上位層に向かって確認するとよい。
  2. YAMAHA及びCiscoとも、設定コマンドを入力した時点で設定内容が反映されるので注意すること。
  3. CiscoはデフォルトではネットワークI/Fがshutdown状態なので、"no shut"で有効化する必要がある。
  4. Ciscoの場合は、以下の設定をしておくと便利である。
    1. DNSを引かないようにする。
      グローバル設定モードで、
      Router(config)#no ip domain-lookup
    2. コマンド入力中のログ出力による割り込みを抑制する。
      グローバル設定モードで、
      Router(config)#line console 0 (ライン設定モードに入る)
      Router(config-line)#logging synchronous

5 実技テスト

5.1 実技テストの内容

  1. 本実験テーマの理解度を確認するため、実技テストを行う。
  2. 実技テストはグループ単位で行う。
  3. アドレス設計(グローバルアドレス,プライベートアドレスの理解)、ダイナミックルーティング設定を行う。
  4. アドレス設計シートは、実技テスト後にグループ構成員の氏名を記入して提出すること。(問題用紙は持ち帰ること)

5.2 片づけ

各機材は、同梱品を含めて紛失がないように取り扱うこと。
(片付ける際は、本体は箱に貼られた番号の通りに箱詰めすること)

USBシリアル変換ケーブル、貸出LANケーブルは別回収です。(ルーターの箱に入れないこと)


メモ

[ Back ]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2016-06-21 (火) 12:08:41 (1181d)